Ellin.com
Not Very Interesting
Spring Cloud Config
Spring Cloud Config

Enabling Automagic config on TAS

Tested with 2.3.1.RELEASE

Add the Config client

1
2
3
4
<dependency>
    <groupId>io.pivotal.spring.cloud</groupId>
    <artifactId>spring-cloud-services-starter-config-client</artifactId>
</dependency>

Downgrade the conflig starter to 2.3 to avoid using the new cfenv. Make sure the spring-cloud-starter-dependencies is first in the list.

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
<dependencyManagement>
		<dependencies>
			<dependency>
				<groupId>io.pivotal.spring.cloud</groupId>
				<artifactId>spring-cloud-services-dependencies</artifactId>
				<version>2.2.1.RELEASE</version>
				<type>pom</type>
				<scope>import</scope>
			</dependency>
			<dependency>
				<groupId>org.springframework.cloud</groupId>
				<artifactId>spring-cloud-dependencies</artifactId>
				<version>${spring-cloud.version}</version>
				<type>pom</type>
				<scope>import</scope>
			</dependency>
		</dependencies>
	</dependencyManagement>

References


Last modified on 2020-07-14

comments powered by Disqus